CyberTank compatible with 1.7

The current version of CyberTank 0.4.4.6 is fully compatible with the game update 1.7.